FORUM PTT -  Strona Główna
FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy RejestracjaRejestracja  ZalogujZaloguj

Odpowiedz do tematu
Poprzedni temat :: Następny temat
Naprawa dodatku
Autor Wiadomość
Peeet2005 
super trainz
Peeet2005


Pomógł: 8 razy
Wiek: 59
Dołączył: 18 Sty 2011
Posty: 493
Skąd: Kraków
Wysłany: 02-11-2019, 17:35   Naprawa dodatku

Witam!
Może ktoś będzie wiedział jak naprawić dodatek, który jest sygnalizowany takim błędem:

- <kuid:171841:26034> VE192: Tag 'trainz-build' does not contain a valid float list: 1.1.1 + SP4

Przy kopiowaniu moich dodatków z T:ANE do TRS19 na niektórych wyskoczyły mi takie błędy.

W końcu dałem się skusić ofertą Hellowinową i przy wykorzystaniu punktów premii wyszło mi niecałe 18$.
_________________
KUID:269437
 
 
 
RBach 
znawca
Toromistrz



Pomógł: 277 razy
Wiek: 44
Dołączył: 26 Lut 2008
Posty: 4110
Skąd: Gościcino Centralne
Wysłany: 02-11-2019, 17:45   

Przecież masz napisane :-D
Trainz build jest liczbą "z przecinkiem" (float) - w przypadku Trainzów rolę przecinka spełnia KROPKA!, czyli np. 2.0, 2.9, 3.3, 4.5 i tak dalej. Bez kropkoprzecinka też - czyli 2 jest traktowane jak 2.0
W przypadku podanego błędu ktos wpisał "1.1.1 + SP4", co nijak nie spełnia wymogu "bycia liczbą" :-D Powinno być np 1.1 bo te pozostałe znaki i kropkoprzecinki dają błąd :-D
To działa jak w Excelu - format "liczbowy" i format "tekstowy" :mrgreen:

Swoją drogą - kolejna wersja, kolejne błędy :-D
_________________
Moje dodatki
Instrukcje kolejowe
KUID:263713
aktualny release skryptów sygnalizacji v5.3: 11.04.2020
Ostatnio zmieniony przez RBach 02-11-2019, 17:51, w całości zmieniany 1 raz  
 
 
 
Peeet2005 
super trainz
Peeet2005


Pomógł: 8 razy
Wiek: 59
Dołączył: 18 Sty 2011
Posty: 493
Skąd: Kraków
Wysłany: 03-11-2019, 10:28   

Dzięki za wsparcie, ale jak już jestem przy głosie, to przy okazji poruszę sprawę dodatków Samplaire'a. Otóż może wiecie, może nie, ale sporo dodatków ma problem pod TRS19 i wyświetla je na czerwono dając komunikat:
- <kuid2:132952:100955:10> VE34: Alias mesh 'bridge02_6m.im' not found in latest version (<kuid2:132952:100944:19>) of dependency <kuid:132952:100944>.
- <kuid2:132952:100955:10> VE76: Unable to load mesh file: 'bridge02_6m.im'

Te błędy powtarzają się wszędzie no bo nigdzie nie mam tej biblioteki <kuid2:132952:100944:19> ani żadnej wcześniejszej wersji. Jak to działało pod TANE to nie wiem....
_________________
KUID:269437
 
 
 
rysztur
zaawansowany


Pomógł: 56 razy
Dołączył: 11 Kwi 2008
Posty: 919
Skąd: Bydgoszcz
Wysłany: 03-11-2019, 10:42   

W bibliotece meshy brak wymienionych w komunikacie błędu.
Miałem to samo, przerobiłem z trzynastki na dziewiętnastkę i dodałem ręcznie brakujące meshe.
 
 
Peeet2005 
super trainz
Peeet2005


Pomógł: 8 razy
Wiek: 59
Dołączył: 18 Sty 2011
Posty: 493
Skąd: Kraków
Wysłany: 03-11-2019, 11:56   

:-D
No faktycznie pomogło! Zrobiłem podobnie i już wszystkie te wadliwe są OK :-) Trochę tylko zajmie poprawianie tego wszystkiego ale ważna jest metoda ;-)
_________________
KUID:269437
 
 
 
samplaire
znawca
i na dodatek dziad



Pomógł: 77 razy
Wiek: 50
Dołączył: 22 Wrz 2009
Posty: 3106
Skąd: Wawa/Gorz/Szcz
Wysłany: 11-11-2019, 03:05   

Sprawę zgłosiłem w bug report.

Gdy masz zainstalowane 2 wersje biblioteki, przy czym jedna jest obsolete, to system I TAK SZUKA w tej obsolete - to oczywisty błąd, ale tak jest. Zrobiłem eksperyment: stworzyłem nowe 2 dodatki oparte o bibliotekę, której dałem wersję :1. Zainstalowałem te dodatki i bibliotekę na drugim kompie. Teraz zrobiłem trzeci dodatek, który powędrował do biblioteki w wersji :2. Te 2 rzeczy zainstalowałem na drugim kompie. Dodatek 3 zgłaszał błąd, że go nie ma w bibliotece. Był w aktualnej :2, ale nie było go w :1. Skasowałem :1 i wszystko wróciło do normy.


Tak więc rozwiązaniem jest usunięcie tej nieaktualnej i wszystko wróci do normy.


Poza tym pamiętajcie - jesli macie jakiś problem z moim dodatkiem, to piszcie do mnie! Mój adres email jest w każdym dodatku, można napisacć priva tu, albo na auranie!
_________________
KUID:132952
Tu moje dodatki ciurkiem
 
 
 
Peeet2005 
super trainz
Peeet2005


Pomógł: 8 razy
Wiek: 59
Dołączył: 18 Sty 2011
Posty: 493
Skąd: Kraków
Wysłany: 02-07-2020, 12:09   Błąd w pliku IM

Witam!
Mam taki mały problem z dodatkiem D1 gdzie mi wyskakuje błąd

! <kuid:174085:20089> MeshObject::FindNamedAttachmentPoint> unable to find named attachment point on stitched mesh (mesh index 0, att '', asset <kuid:174085:20089> "D1")
- <kuid:174085:20089> MeshObject::CreateMeshParticle> Can't find attachment point '' for name effect on asset '<kuid:174085:20089> "D1"'

Niestety nie znam się na tyle żeby to poprawić, może ktoś by tu pomógł? ;-)
_________________
KUID:269437
 
 
 
jagg
super user


Pomógł: 12 razy
Dołączył: 16 Lis 2008
Posty: 166
Skąd: cz
Wysłany: 07-07-2020, 11:25   

Obecně je důležité vědět, ve které verzi Trainz chyba vyskakuje. Tady je chyba v chybějícím attachment pointu, takže buď:
1) doplnit attachment point a.name0 do im meshe
nebo
2) smazat subkontejner effects v configu a mít pouze čistou tabuli bez popisu

Nevím, jestli cedule D1 má mít nějaký popis, pokud ne, varianta 2 je optimální. Model používá polské znaky v názvech materiálů a txt souborů a textur = chyba, je potřeba nahradit.
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group