FORUM PTT -  Strona Główna
FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy RejestracjaRejestracja  ZalogujZaloguj

Odpowiedz do tematu
Poprzedni temat :: Następny temat
Przenosiny mapy z TRS2019 do TANE
Autor Wiadomość
Patrykos
zaawansowany



Pomógł: 8 razy
Dołączył: 25 Lut 2008
Posty: 811
Skąd: Imielin
Wysłany: 17-04-2022, 22:32   Przenosiny mapy z TRS2019 do TANE

Dobry wieczór,
doszedłem do wniosku, że na chwilę obecną przesiadka na TRS2019 to nieporozumienie. Zacząłem budować mapę w 2019 wykorzystując warstwy i chciałbym kontynuować jej rozbudowę w TANE. Kłopotu z bazą danych nie ma, natomiast po zmianie buildu i wczytaniu do TANE, mapa nie ma warstw. Czy jest jakiś ficzer, dzięki któremu odzyskam warstwy z 2019 w TANE, czy już pozamiatane?
_________________
Pozdrawiam, Patryk.
http://www.patrykos.kolej.org.pl/ / https://www.facebook.com/PatrykosTrainz/
 
 
 
Pawel_15 
znawca
Mann Bonk



Pomógł: 66 razy
Wiek: 32
Dołączył: 30 Maj 2009
Posty: 2068
Skąd: Bonk (Westpreussen)
Wysłany: 17-04-2022, 22:43   

Jak najnowszy build to zapomnij. Jak wersja pre-SP1 to trzeba zmienić kilka rzeczy i mapa pójdzie na TANE.
 
 
Patrykos
zaawansowany



Pomógł: 8 razy
Dołączył: 25 Lut 2008
Posty: 811
Skąd: Imielin
Wysłany: 18-04-2022, 12:41   

Paweł, a te kilka rzeczy znaczy co?
_________________
Pozdrawiam, Patryk.
http://www.patrykos.kolej.org.pl/ / https://www.facebook.com/PatrykosTrainz/
 
 
 
Pawel_15 
znawca
Mann Bonk



Pomógł: 66 razy
Wiek: 32
Dołączył: 30 Maj 2009
Posty: 2068
Skąd: Bonk (Westpreussen)
Wysłany: 18-04-2022, 13:26   

Kilka dodatków trzeba podmienić, szczegółów nie znam. Zapytaj Radka, będzie wiedział bo będzie przenosił naszą mapę z trawnika pre-SP1 do TANE.
 
 
RBach 
Administrator
Toromistrz


Pomógł: 305 razy
Wiek: 45
Dołączył: 26 Lut 2008
Posty: 4391
Skąd: Gościcino Centralne
Wysłany: 19-04-2022, 11:43   

Może uściślając - nie podmieniamy "dodatków". Dodatki musimy już mieć. Mapa to tylko zapis "co i gdzie stoi", więc zmieniamy wpisy w configach:

Przede wszystkim build mapy i sesji (co oczywiste), oprócz tego w configach mapy i sesji w KUIDLIST trzeba zmienić kuidy dodatków w wersji 4.6+ zmienić na wersję TANE. W kuidtablu zawsze zapisują się kuidy najwyższych posiadanych przez nas wersji.
Jeżeli mamy - na przykład - nasypy SAM-a, to po wstawieniu ich w 19 będą kuidy zainstalowane w 19, co w TANE nie przejdzie, bo one będą "niekompatybilne". Trzeba ręcznie zmienić im w kuidtablu kuidy na takie, jakie mamy w TANE. Polega to na zmianie końcówki numeru wersji KUID2 w danym wpisie.
Przykładowo - mamy w 19 nasypy SAMa na PBRach, kuid2:132952:100923:16. Taki będzie wpis w kuidtablu mapy. W TANE ten nasyp ma kuid kuid2:132952:100923:10 i na taki zmieniamy.
Czyli po przeniesieniu trzeba wylistować zależności, sprawdzić, czy mamy wszystkie "niekompatybilne" i "brakujące" w niższych wersjach kuid2 i ręcznie pozmieniać.
Pewnych rzeczy nie da się obniżyć, chociażby wbudowanej w 19 szarej siatki terenu PBR - wtedy robi się patent - klonuje się szara siatkę z TANE, nadaje jej kuid tej pbrowej i instaluje :-) co od razu zapewni kompatybilność przy wgraniu mapy na powrót do 19.
Generalnie robota długa, nudna i żmudna, ale "dasię". A jeżeli czegoś już naprawdę nie da się patentem, to niestety trzeba się pogodzić, że będzie tego brakować i po prostu na koniec dać "usuń brakujące składniki". Trudno.
_________________
Moje dodatki
Instrukcje kolejowe
KUID:263713
aktualny release skryptów sygnalizacji v5.4: 20.02.2022
 
 
Patrykos
zaawansowany



Pomógł: 8 razy
Dołączył: 25 Lut 2008
Posty: 811
Skąd: Imielin
Wysłany: 19-04-2022, 16:12   

OK, powiedzmy, że dodatki to pół biedy, tylko czemu u licha TANE nie widzi warstw?
TANE wersja 105766 a TRS2019 117026.
_________________
Pozdrawiam, Patryk.
http://www.patrykos.kolej.org.pl/ / https://www.facebook.com/PatrykosTrainz/
 
 
 
RBach 
Administrator
Toromistrz


Pomógł: 305 razy
Wiek: 45
Dołączył: 26 Lut 2008
Posty: 4391
Skąd: Gościcino Centralne
Wysłany: 19-04-2022, 17:28   

Bo nie ma kompatybilności wstecznej. Z tym musisz się pogodzić.
_________________
Moje dodatki
Instrukcje kolejowe
KUID:263713
aktualny release skryptów sygnalizacji v5.4: 20.02.2022
 
 
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group